Supervisor

python 3使用supervisor做守护进程

问题 centos 7系统,python 3.6环境下用pip install supervisor会报错, 简单说就是supervisor不支持python 3 [root@li999-188 python-supervisor]# pip3 install supervisor Collecting supervisor Using cached https://files.pythonhosted.org/packages/44/60/698e54b4a4a9b956b2d709b4b7b676119c833d811d53ee2500f1b5e96dc3/supervisor-3.3.4.tar.gz Complete output from command python setup.py egg_info: Supervisor requires Python 2.4 or later but does not work on any version of Python 3. You are using version 3.6.6 (default, Aug 6 2018, 01:04:23) [GCC 4.8.5 20150623 (Red Hat 4.8.5-16)]. Please install using a support...
执行时间: 34.779071807861 毫秒